Adrian Flux : 01553 845 945

The Mitsubishi Pajero Owners ClubŪ
The Mitsubishi Pajero, Shogun, Montero, Challenger, Raider and EVO 4x4 Owner's Club
 
The POCUK - it's not just a Club, it's a way of life!

 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
Click here to link to the Pajero Owners Club UK FaceBook Group!POCUK FaceBook Group  POCUK home pagePOCUK Home  POCUK ForumsPOCUK Forums  CalendarCalendar

electrical troubleshooting help


 
Post new topic   Reply to topic    The Mitsubishi Pajero Owners ClubŪ Forum Index -> Pinin & Jnr technical forum
View previous topic :: View next topic  
Author Message
malkog
Newbie
Newbie


Age: 27
Zodiac: Capricorn
Joined: 11 Jan 2021
Posts: 2
Location: Malta

PostPosted: Mon Dec 27, 2021 19:50    Post subject: electrical troubleshooting help Reply with quote

Good evening Ladies and Gents,

I require some help regarding a persisting issue I've been having with my 1.1 Junior.

Long story short: works fine 90% of the time, but turns off signal to one of the coil packs at random. Please keep reading for further info Smile

So here it goes:

Starts and goes normally most of the time, but at random, the check engine light will turn on (returns code 23: cam position sensor) and starts working very roughly, eventually no more power and leaves you stranded in the middle of the road.
Once it fully cools, it's as if nothing ever happened.
Same problem can also be replicated when continuously restarting the engine when stationary, so temperature is not a factor.

When working correctly/incorrectly, moving/pulling/tapping all wires and sensors does nothing, so it's not a loose contact.

When working incorrectly, I can confirm that there is no 5V signal to the front coil.

I have replaced the cam sensor, cleaned all visible plugs, removed and cleaned the ECU (looking for a replacement right now), replaced oil, oil filter. spark plugs, fuel filter, cleaned injectors, air filter, cleaned throttle body.

There are no visible vacuum leaks, and I don't suspect this is the issue since it also happens when the airbox is removed, which is essentially a massive vacuum leak.

One (very) strange thing I noticed is when driving without stopping, this rarely happens, but as soon as you stop.....and turn off the headlights, check engine light immediately turns on.
Last week also the headunit turned off on its own while driving, and check engine turned on, coil turned off, and left me stranded :/

Any help is greatly appreciated Smile I am on the verge of scrapping the vehicle.

Regards,
Malcolm
Back to top
View user's profile Send personal message
Google
Sponsor







PostPosted: Mon Dec 27, 2021 19:50    Post subject: Google Ads keep the POCUK free to join!


Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Mitsubishi Pajero Owners ClubŪ Forum Index -> Pinin & Jnr technical forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2002 phpBB Group